Install driver epson l110 dengan Tp-Link TL-WPS510U di ubuntu 14.04

Bismillah…

saya install driver nya di ubuntu 14.04 Lts amd64 untuk setting  Tp-Link TL-WPS510U tidak akan di bahas di kesempatan kali ini , jadi inti nya di kasus ini printer epson l110 nya jadi printer share dengan perantara Tp-link  TL-WPS510U , ok berikut langkah nya

Download driver nya

driver epson l110 untuk linux .deb & .Rpm  bisa di download di  http://download.ebz.epson.net/dsc/du/02/DriverDownloadInfo.do?LG2=EN&CN2=&DSCMI=18787&DSCCHK=cd4ad419e3805cfac26d6492d12e38fc7da11822

Install

jika anda beruntung install package deb driver epson  yang kita download bisa dengan hanya di double klik dan ikutin wizard ubuntu software center

3

nah di kasus saya ada sedikit masalah ternyata ada bebrapa dependencies  yang di butuhkan si driver belum ada di PC tersebut  dan tidak bisa di fix kan melalui ubuntu software center , kemudian saya coba  install melalui terminal ,

pindah ke lokasi file deb nya

[email protected]:/home/keuangan# cd Downloads/
[email protected]:/home/keuangan/Downloads# ls
epson-inkjet-printer-201207w_1.0.0-1lsb3.2_amd64.deb

kemudian install

[email protected]:/home/keuangan/Downloads# dpkg -i epson-inkjet-printer-201207w_1.0.0-1lsb3.2_amd64.deb

nah terlihatlah error dependencies nya


Selecting previously unselected package epson-inkjet-printer-201207w.
(Reading database ... 163651 files and directories currently installed.)
Preparing to unpack epson-inkjet-printer-201207w_1.0.0-1lsb3.2_amd64.deb ...
Unpacking epson-inkjet-printer-201207w (1.0.0-1lsb3.2) ...
dpkg: dependency problems prevent configuration of epson-inkjet-printer-201207w:
 epson-inkjet-printer-201207w depends on lsb (>= 3.2); however:
  Package lsb is not installed.

dpkg: error processing package epson-inkjet-printer-201207w (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 epson-inkjet-printer-201207w

kemudian kita coba install lsb nya


[email protected]:/home/keuangan/Downloads# apt-get install lsb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 lsb : Depends: lsb-core (>= 4.1+Debian11ubuntu6) but it is not going to be installed
       Depends: lsb-graphics (>= 4.1+Debian11ubuntu6) but it is not going to be installed
       Depends: lsb-cxx (>= 4.1+Debian11ubuntu6) but it is not going to be installed
       Depends: lsb-desktop (>= 4.1+Debian11ubuntu6) but it is not going to be installed
       Depends: lsb-printing (>= 4.1+Debian11ubuntu6) but it is not going to be installed
       Depends: lsb-languages (>= 4.1+Debian11ubuntu6) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

ok ,


[email protected]:/home/keuangan/Downloads# apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  alien at build-essential cpp-4.8 debhelper debugedit dh-apparmor dpkg-dev
  fakeroot g++ g++-4.8 gcc-4.8 gcc-4.8-base heirloom-mailx lib32z1
  libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl
  libasan0 libatomic1 libc-dev-bin libc6 libc6-dbg libc6-dev libc6-i386
  libdpkg-perl libfakeroot libgcc-4.8-dev libgomp1 libitm1 libjpeg62
  libmail-sendmail-perl libpod-plainer-perl libquadmath0 librpm3 librpmbuild3
  librpmio3 librpmsign1 libsigsegv2 libstdc++-4.8-dev libstdc++6
  libsys-hostname-long-perl libtsan0 lsb lsb-core lsb-cxx lsb-desktop
  lsb-graphics lsb-invalid-mta lsb-languages lsb-multimedia lsb-printing
  lsb-security m4 ncurses-term pax po-debconf rpm rpm-common rpm2cpio
Suggested packages:
  lsb-rpm default-mta mail-transport-agent gcc-4.8-locales dh-make rpm-i18n
  apparmor-easyprof debian-keyring g++-multilib g++-4.8-multilib gcc-4.8-doc
  libstdc++6-4.8-dbg gcc-4.8-multilib libgcc1-dbg libgomp1-dbg libitm1-dbg
  libatomic1-dbg libasan0-dbg libtsan0-dbg libquadmath0-dbg glibc-doc
  libstdc++-4.8-doc libmail-box-perl elfutils
Recommended packages:
  libqt3-mt
The following NEW packages will be installed:
  alien at build-essential debhelper debugedit dh-apparmor dpkg-dev fakeroot
  g++ g++-4.8 heirloom-mailx lib32z1 libalgorithm-diff-perl
  libalgorithm-diff-xs-perl libalgorithm-merge-perl libc6-i386 libfakeroot
  libjpeg62 libmail-sendmail-perl libpod-plainer-perl librpm3 librpmbuild3
  librpmio3 librpmsign1 libsigsegv2 libstdc++-4.8-dev
  libsys-hostname-long-perl lsb lsb-core lsb-cxx lsb-desktop lsb-graphics
  lsb-invalid-mta lsb-languages lsb-multimedia lsb-printing lsb-security m4
  ncurses-term pax po-debconf rpm rpm-common rpm2cpio
The following packages will be upgraded:
  cpp-4.8 gcc-4.8 gcc-4.8-base libasan0 libatomic1 libc-dev-bin libc6
  libc6-dbg libc6-dev libdpkg-perl libgcc-4.8-dev libgomp1 libitm1
  libquadmath0 libstdc++6 libtsan0
16 upgraded, 44 newly installed, 0 to remove and 309 not upgraded.
1 not fully installed or removed.
Need to get 41,5 MB/46,9 MB of archives.
After this operation, 61,1 MB of additional disk space will be used.
Do you want to continue? [Y/n] y

setelah proses instalasi paket pendukungnya selesai kita coba install lagi driver nya


[email protected]:/home/keuangan/Downloads# dpkg -i epson-inkjet-printer-201207w_1.0.0-1lsb3.2_amd64.deb 
(Reading database ... 168680 files and directories currently installed.)
Preparing to unpack epson-inkjet-printer-201207w_1.0.0-1lsb3.2_amd64.deb ...
Unpacking epson-inkjet-printer-201207w (1.0.0-1lsb3.2) over (1.0.0-1lsb3.2) ...
cups stop/waiting
cups start/running, process 15749
Setting up epson-inkjet-printer-201207w (1.0.0-1lsb3.2) ...
cups stop/waiting
cups start/running, process 15808
Processing triggers for libc-bin (2.19-0ubuntu6) ...
[email protected]:/home/keuangan/Downloads#

Add Printer

klik search on your computer kemudian ketik printer  kemudian add printer –> pilih find network printer

Screenshot from 2016-08-27 13-39-12

masukan ip print server tp-link  TL-WPS510U nya (jangan lupa usb printernya di colokin ke print server 🙂 )

7

kemudian forward , sisa nya tiggal ikutin wizard nya ,

selamat mencoba 🙂

No Comments, Be The First!

Your email address will not be published.

Time limit is exhausted. Please reload CAPTCHA.